Page tree
Skip to end of metadata
Go to start of metadata

 

Introduction

Our software has been designed to run on a Microsoft® Windows® platform.

Blade® v1.0 - 1.9

Blade® will run on the following:

  • Microsoft Windows XP, 2003, Vista, 2008 and Windows 7
  • 32 and 64 bit
  • Blade® also requires Microsoft .Net Framework v4

  • (warning) Windows 8 is not supported for Blade® version 1.0 through to 1.9

     

Blade® v1.10+

  • Windows 10
  • Windows 8
  • Windows 7
  • Windows Vista SP1 or later
  • Windows XP SP3
  • Windows XP SP2 x64 Edition
  • Windows Server 2008 (Server Core not supported)
  • Windows Server 2008 R2 (Server Core not supported)
  • Blade® also requires the Microsoft .NET Framework v4